Degraded response times for Boom platform

Incident Report for Boom

Resolved

This incident is resolved, with no degraded performance since around 1:15pm CDT.
Posted Apr 09, 2026 - 16:19 CDT

Monitoring

We continue to monitor application performance. We've seen sustained recovery for the last 40 minutes and will provide further updates as we continue to monitor.
Posted Apr 09, 2026 - 13:08 CDT

Investigating

We are continuing to investigate the cause of degraded performance
Posted Apr 09, 2026 - 12:01 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 10:40 CDT

Identified

We've identified an issue that has been causing some degraded response times for the Boom platform and are in the process of deploying the fix
Posted Apr 09, 2026 - 10:04 CDT
This incident affected: BoomScreen (Portal, API).