Boom platform incident

Incident Report for Boom

Resolved

This issue is fully resolved, and we are working to improve processes to avoid a repeat incident in the future.
Posted Mar 16, 2026 - 15:17 CDT

Monitoring

We are monitoring the Boom platform after restoring the services
Posted Mar 16, 2026 - 13:45 CDT

Identified

We have identified the cause of the issue and are working to restore service
Posted Mar 16, 2026 - 13:32 CDT

Investigating

We are investigating an issue that may be impacting the Boom platform.
Posted Mar 16, 2026 - 13:27 CDT
This incident affected: BoomScreen (Portal, API) and BoomReport (API).