Boom platform outage

Incident Report for Boom

Resolved

An infrastructure component used broadly throughout the Boom platform was under high load which resulted in an outage. This has been resolved and all services are operating normally.
Posted Mar 05, 2026 - 16:55 CST

Monitoring

A fix has been implemented and services are recovering. We are monitoring for stability.
Posted Mar 05, 2026 - 16:45 CST

Identified

An infrastructure component used broadly throughout the Boom platform has been identified as being under high load, resulting in the current outage. We are working on remediation.
Posted Mar 05, 2026 - 16:30 CST

Investigating

We are investigating an issue affecting the Boom platform. Users may experience errors or be unable to access services.
Posted Mar 05, 2026 - 16:05 CST
This incident affected: BoomScreen (Portal, API) and BoomReport (API).